Tuesday, August 11, 2009

COMMAND LINE INTERFACE (CLI) SWITCH...

Bookmark and Share
Cisco switchSwitch adalah perangkat keras yang mampu menyatukan semua komputer yang ada dalam satu LAN dan switch tersebut dapat di konfigur.
Berikut ini daftar perintah dasar yang sering digunakan dalam mode CLI (Command Line Interface) :
Ket : sh run tiap kali sesudah CLI switch utk melihat apakah CLI tsb berhasil.
1. Hapus informasi database vlan bawaan switch dengan mengikuti perintah berikut:
Switch#delete flash:vlan.dat
Delete filename [vlan.dat]? [enter]
Delete flash:vlan.dat?[confirm] [enter]
Catatan: jika tidak ada file vlan, maka pesan berikut akan tampil:
%error deleting flash:vlan.dat (No such file or directory)
2. Menghapus file konfigurasi startup dari NVRAM. Ikuti perintah-perintah berikut:
Switch#erase startup-config
Erasing the nvram filesystem will remove all file! Continue? [confirm] [enter]
Erase of nvram: complete
3. Perintah untuk mengecek bahwa nvram telah benar-benar di-delete:
Switch#show nvram
4. Bila nvram telah di hapus, maka perlu dilakukan software restart. Gunakan perintah berikut:
Switch#configure terminal
Switch(config)#reload
System configuration has been modified. Save? [yes/no]:
Ketik n, kemudian tekan [enter]
Proceed with reload? [confirm] [enter]
Reload requested by the console.
Would you like to enter the initial configuration dialog?[yes/no]:
Ketik n, kemudian tekan [enter]
Press RETURN to get started! [enter]
5. Bila anda hendak menganti nama switch dari Switch menjadi Apriandi :
switch>enables
switch#configure terminal
switch(config)#hostname andi
apriandi(config)#exit
6. Menampilkan nama username :
apriandi#configure terminal
apriandi(config)#aaa new-model
7. Mengengkripsi password :
apriandi#configure terminal
apriandi(config)#service password-encryption
8. Memberi ip address pada switch :
apriandi#configure terminal
apriandi(config)#interface vlan 1
apriandi(config-if)#ip address 10.10.20.1 255.255.255.0
apriandi(config-if)#no shutdown
apriandi(config-if)#end
apriandi#
9. Memberi akses vlan,mode koneksi,deskripsi link pada port2 switch :
contoh di port 0/1 ;
apriandi#configure terminal
apriandi(config)#interface FastEthernet 0/1
apriandi(config-if)#switchport acces vlan 2
apriandi(config-if)#switchport mode trunk
apriandi(config-if)#description link ke Switch Budi
apriandi(config-if)#end
apriandi#
10. Memberi password pada switch/Aktfikan password yang telah anda berikan agar setiap kali seseorang hendak masuk ke Privileged EXEC Mode, akan dimintai password :
apriandi(config)#enable password apriandi
atau
apriandi(config)#enable secret apriandi
apriandi(config)#exit
apriandi#exit
11. Untuk memproteksi switch dari yg mencoba login melalui port console :
apriandi#configure terminal
apriandi(config)#line con 0
apriandi(config-line)#password apriandi
apriandi(config-line)#login
apriandi(config)#exit
apriandi#exit
12. Untuk TeLnet/Visual Terminal dan pemberian password TeLnet :
apriandi(config-line)#line vty 0 15
apriandi(config-line)#password apriandi
apriandi(config-line)#login
apriandi(config-line)#end
apriandi#
13. Untuk keluar dari apriandi(config-line)# dan kembali ke Apriandi(config)#, tekan Ctrl+Z atau ketik exit atau
ketik end.
Demikian pula dengan perintah-perintah lainnya.